IPRAN中的IS-IS应用ensp模拟实验

IPRAN中的IS-IS应用ensp模拟实验

IPRAN中的IS-IS主要作用就是打通IP网络,为后续的配置MPLS、BGP、L3VPN、L2VPN提供基础IP网络互通条件。这里我们主要是实现目的有两个:

1、实现CSG— ASG、ASG—P、P—RSG、ASG—RSG之间的Loopback0地址互通。

2、所有设备与U2000网管服务器之间实现互通。

基本的配置原理和方法在之前的《IPRAN中的IS-IS应用》章节中已经详细介绍了,本文主要介绍使用ensp模拟器模拟现网的组网配置情况,为后续的实验内容提供基础环境。

本实验演示IPRAN(HVPN)实验中ISIS基础配置,采用DCN部署采用公网DCN cost值方式。

一、组网需求

组网图如下图所示:

  • RSG1、RSG2角色为RSG(Radio Service Gateway,无线业务侧网关)。
  • P1、P2角色为P设备,仅用作汇聚转发同时作为核心汇聚层BGP的RR(路由反射器)。
  • ASG1、ASG2角色为ASG(Aggregation Site Gateway,汇聚侧网关)。
  • CSG1、CSG2、CSG3、CSG4角色为CSG(Cell Site Gateway,基站侧网关)。
  • CSG1、CSG2归属接入环1; CSG3、CSG4归属接入环2。两个接入环分属不同ISIS进程,相互隔离。
  • U2000 Server作为网络NMS(Network Management System,网络管理系统 )。
  • SW为二层交换机,作为NMS的网关。

二、配置思路

采用如下的思路配置:

1、配置所有设备端口,实现直连端口互通。

2、配置所有设备ISIS进程并将接口加入对应进程中,实现相同ISIS进程之间设备Loopback0地址和接口地址之间的全互通。

3、配置U2000网管服务器与RSG之间对接,采用VRRP保护方式,将U2000网管路由引入核心汇聚层ISIS中,实现核心汇聚设备的管理。

4、配置ASG的ISIS路由引入。即将ISIS 1000中网管路由引入到ISIS 1和ISIS2,同时将ISIS 1和ISIS2中Loopback0和接口地址路由引入到ISIS 1000,实现接入层设备的管理。

三、数据规划

参数 备注
isis 接入区域:1 汇聚区域:100 使能IS-IS路由进程。
network-entity RSG1:49.0001.0100.0000.0001.00
RSG2:49.0001.0100.0000.0002.00
P1:49.0001.0100.0000.0003.00
P2:49.0001.0100.0000.0004.00
ASG1:49.0001.0100.0000.1001.00
ASG2:49.0001.0100.0000.1002.00
CSG1:49.0001.0100.0000.2001.00
CSG2:49.0001.0100.0000.2002.00
CSG3:49.0001.0100.0000.2003.00
CSG4:49.0001.0100.0000.2004.00
设置网络实体名称。 区域ID根据用户需求设计。 System ID 必须全网唯一。通过Loopback0接口的IP地址来计算System ID,以IP 地址10.11.101.1为例:将10.11.101.1 的每个十进制 数都扩展为3 位,不足 3 位的在前面补0,成为010.011.101.001;将扩展后的数字分为3 段,每段由4 位数字组成,成为 0100.1110.1001,即为 System ID。 ASG下带多个接入环时,需要部署多个ISIS进程,此时推荐每个进程System ID也唯一,此时可以使用“进程ID”+“Loopback IP”方式规划(分别做为System ID高位和低位)。本例中未进行高低位换算,仍以Loopback0接口的IP地址来计算。
is-level Level-2 设置路由器的Level级别。
cost-style Wide 接收或发送开销类型为wide的路由。
is-name 与设备名称配置一致。如CSG1设备规划is-name为CSG1 为IS-IS进程配置动态主机名
isis cost 接入环除ASG之间互连链路外,其他链路cost值设置100。 接入环ASG之间链路cost值设置为2000。 汇聚环除RSG之间互连链路外,其他链路cost值使用默认值10。 汇聚环RSG之间链路cost值设置为45。 指定进行SPF计算时接口的链路开销。
timer spf 1 50 50 设置SPF计算最大延迟为1秒,初始延迟为50毫秒,递增时间为50毫秒。
timer lsp-generation 1 50 50 设置产生LSP的最大延迟为1秒,初始延迟为50毫秒,递增延迟时间为50毫秒。
flash-flood level-2 使能LSP快速扩散特性,以便加快IS-IS网络的收敛速度。
set-overload on-startup - 配置过载标志位。
bfd all-interfaces enable - 配置使能BFD for ISIS。

四、数据配置

说明: 默认情况下,控制台用户显示功能为打开状态,设备的所有的调试/日志/告警信息都会在调测过程不断显示,如果不想显示,可通过<HUAWEI> undo terminal monitor命令关闭终端显示功能。

1、配置所有设备端口,实现直连端口互通。

RSG1:

<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname RSG1
[RSG1]interface LoopBack 0
[RSG1-LoopBack0]ip address 10.0.0.1 32
[RSG1-LoopBack0]quit     
[RSG1]interface Eth-Trunk1    
[RSG1-Eth-Trunk1]mode lacp-static     
[RSG1-Eth-Trunk1]quit     
[RSG1]int Eth-Trunk1.1000
[RSG1-Eth-Trunk1.1000]vlan-type dot1q 1000
[RSG1-Eth-Trunk1.1000]ip address 172.16.0.1 30    
[RSG1-Eth-Trunk1.1000]quit 
[RSG1]interface GigabitEthernet 0/0/0
[RSG1-GigabitEthernet0/0/0]eth-trunk 1    
[RSG1-GigabitEthernet0/0/0]quit
[RSG1]interface GigabitEthernet 0/0/1
[RSG1-GigabitEthernet0/0/1]eth-trunk 1
[RSG1-GigabitEthernet0/0/1]quit
[RSG1]interface GigabitEthernet 0/0/2
[RSG1-GigabitEthernet0/0/2]ip address 172.16.0.5 30
[RSG1-GigabitEthernet0/0/2]quit
[RSG1]

RSG2:

<Huawei>sys
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname RSG2
[RSG2]interface LoopBack 0
[RSG2-LoopBack0]ip address 10.0.0.2 32
[RSG2-LoopBack0]quit     
[RSG2]interface Eth-Trunk1    
[RSG2-Eth-Trunk1]mode lacp-static     
[RSG2-Eth-Trunk1]quit     
[RSG2]int Eth-Trunk1.1000
[RSG2-Eth-Trunk1.1000]vlan-type dot1q 1000
[RSG2-Eth-Trunk1.1000]ip address 172.16.0.2 30    
[RSG2-Eth-Trunk1.1000]quit 
[RSG2]interface GigabitEthernet 0/0/0
[RSG2-GigabitEthernet0/0/0]eth-trunk 1    
[RSG2-GigabitEthernet0/0/0]quit
[RSG2]interface GigabitEthernet 0/0/1
[RSG2-GigabitEthernet0/0/1]eth-trunk 1
[RSG2-GigabitEthernet0/0/1]quit
[RSG2]interface GigabitEthernet 0/0/2
[RSG2-GigabitEthernet0/0/2]ip address 172.16.0.9 30
[RSG2-GigabitEthernet0/0/2]quit
[RSG2]

其余设备配置类似,此处省略,需特别注意ASG设备之间用于接入环闭环的子接口,以ASG2为例:

[ASG2]interface GigabitEthernet 0/0/1.1
[ASG2-GigabitEthernet0/0/1.1]vlan-type dot1q 1    
[ASG2-GigabitEthernet0/0/1.1]ip address 172.16.2.14 30
[ASG2-GigabitEthernet0/0/1.1]quit
[ASG2]interface GigabitEthernet 0/0/1.2
[ASG2-GigabitEthernet0/0/1.2]vlan-type dot1q 2
[ASG2-GigabitEthernet0/0/1.2]ip address 172.16.2.30 30
[ASG2-GigabitEthernet0/0/1.2]quit
[ASG2]

配置完成后验证:以RSG1为例,RSG1 ping RSG2互联接口:

[RSG1]ping 172.16.0.2
  PING 172.16.0.2: 56  data bytes, press CTRL_C to break
    Reply from 172.16.0.2: bytes=56 Sequence=1 ttl=255 time=50 ms
    Reply from 172.16.0.2: bytes=56 Sequence=2 ttl=255 time=50 ms
    Reply from 172.16.0.2: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 172.16.0.2: bytes=56 Sequence=4 ttl=255 time=40 ms
    Reply from 172.16.0.2: bytes=56 Sequence=5 ttl=255 time=50 ms

  --- 172.16.0.2 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 40/48/50 ms

2、配置所有设备ISIS进程并将接口加入对应进程中,实现相同ISIS进程之间设备Loopback0地址和接口地址之间的全互通。

RSG1:

// 全局使能BFD
[RSG1]bfd
[RSG1-bfd]quit
[RSG1]

// 配置isis 1000进程
[RSG1]isis 1000
[RSG1-isis-1000] is-level level-2
[RSG1-isis-1000] cost-style wide
[RSG1-isis-1000] timer lsp-generation 1 50 50 level-2
[RSG1-isis-1000] flash-flood level-2
[RSG1-isis-1000] bfd all-interfaces enable
[RSG1-isis-1000] bfd all-interfaces min-tx-interval 100 min-rx-interval 100
[RSG1-isis-1000] network-entity 49.0001.0100.0000.0001.00
[RSG1-isis-1000] is-name RSG1
[RSG1-isis-1000] timer spf 1 50 50
[RSG1-isis-1000] traffic-eng level-2
[RSG1-isis-1000] log-peer-change
[RSG1-isis-1000] set-overload on-startup
[RSG1-isis-1000]quit
[RSG1]

// 配置接口isis
[RSG1]interface LoopBack 0
[RSG1-LoopBack0]isis enable 1000
[RSG1-LoopBack0]quit    
[RSG1]interface Eth-Trunk1.1000    
[RSG1-Eth-Trunk1.1000]isis enable 1000
[RSG1-Eth-Trunk1.1000]isis cost 45
[RSG1-Eth-Trunk1.1000]quit
[RSG1]interface GigabitEthernet 0/0/2
[RSG1-GigabitEthernet0/0/2]isis enable 1000
[RSG1-GigabitEthernet0/0/2]isis cost 10
[RSG1-GigabitEthernet0/0/2]quit
[RSG1]

其余设备配置类似,此处省略,需特别注意端口的cost值设置

配置完成后验证:可查询到ISIS邻居信息、BFD会话信息及ISIS同进程路由信息,以ASG1为例:

// 查询ISIS邻居信息
[ASG1]display isis peer 

                        Peer information for ISIS(1000)

  System Id     Interface          Circuit Id       State HoldTime Type     PRI
-------------------------------------------------------------------------------
P1              GE0/0/0            P1.03             Up   8s       L2       64 
ASG2            GE0/0/1            ASG1.02           Up   27s      L2       64 

Total Peer(s): 2

                          Peer information for ISIS(1)

  System Id     Interface          Circuit Id       State HoldTime Type     PRI
-------------------------------------------------------------------------------
CSG1            GE0/0/2            ASG1.01           Up   26s      L2       64 
ASG2            GE0/0/1.1          ASG1.02           Up   29s      L2       64 

Total Peer(s): 2

                          Peer information for ISIS(2)

  System Id     Interface          Circuit Id       State HoldTime Type     PRI
-------------------------------------------------------------------------------
CSG3            GE0/0/3            ASG1.01           Up   24s      L2       64 
ASG2            GE0/0/1.2          ASG1.02           Up   30s      L2       64 

Total Peer(s): 2

// 查询BFD会话信息
[ASG1]display bfd session all
--------------------------------------------------------------------------------
Local Remote     PeerIpAddr      State     Type        InterfaceName            
--------------------------------------------------------------------------------

8192  8198       172.16.1.1      Up        D_IP_IF     GigabitEthernet0/0/0     
8193  8193       172.16.1.10     Up        D_IP_IF     GigabitEthernet0/0/1     
8194  8194       172.16.2.14     Up        D_IP_IF     GigabitEthernet0/0/1.1   
8195  8195       172.16.2.30     Up        D_IP_IF     GigabitEthernet0/0/1.2   
8196  8192       172.16.2.2      Up        D_IP_IF     GigabitEthernet0/0/2     
8197  8192       172.16.2.18     Up        D_IP_IF     GigabitEthernet0/0/3     
--------------------------------------------------------------------------------
     Total UP/DOWN Session Number : 6/0

// ISIS同进程路由信息
[ASG1]display isis 1000 route 

                        Route information for ISIS(1000)
                        --------------------------------

                      ISIS(1000) Level-2 Forwarding Table
                      -----------------------------------

IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
-------------------------------------------------------------------------------
172.16.1.4/30        20         NULL    GE0/0/1         172.16.1.10     A/-/-/-
172.16.0.4/30        20         NULL    GE0/0/0         172.16.1.1      A/-/-/-
172.16.0.12/30       20         NULL    GE0/0/0         172.16.1.1      A/-/-/-
10.0.0.4/32          20         NULL    GE0/0/0         172.16.1.1      A/-/-/-
                                        GE0/0/1         172.16.1.10    
10.0.1.2/32          10         NULL    GE0/0/1         172.16.1.10     A/-/-/-
172.16.1.0/30        10         NULL    GE0/0/0         Direct          D/-/L/-
10.0.0.3/32          10         NULL    GE0/0/0         172.16.1.1      A/-/-/-
172.16.1.8/30        10         NULL    GE0/0/1         Direct          D/-/L/-
10.0.1.1/32          0          NULL    Loop0           Direct          D/-/L/-
10.0.0.2/32          30         NULL    GE0/0/0         172.16.1.1      A/-/-/-
                                        GE0/0/1         172.16.1.10    
172.16.0.0/30        65         NULL    GE0/0/0         172.16.1.1      A/-/-/-
172.16.0.8/30        30         NULL    GE0/0/0         172.16.1.1      A/-/-/-
                                        GE0/0/1         172.16.1.10    
10.0.0.1/32          20         NULL    GE0/0/0         172.16.1.1      A/-/-/-
     Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                               U-Up/Down Bit Set

[ASG1]display isis 1 route

                         Route information for ISIS(1)
                         -----------------------------

                        ISIS(1) Level-2 Forwarding Table
                        --------------------------------

IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
-------------------------------------------------------------------------------
10.0.2.2/32          200        NULL    GE0/0/2         172.16.2.2      A/-/-/-
172.16.2.0/30        100        NULL    GE0/0/2         Direct          D/-/L/-
172.16.2.8/30        300        NULL    GE0/0/2         172.16.2.2      A/-/-/-
10.0.2.1/32          100        NULL    GE0/0/2         172.16.2.2      A/-/-/-
172.16.2.4/30        200        NULL    GE0/0/2         172.16.2.2      A/-/-/-
172.16.2.12/30       2000       NULL    GE0/0/1.1       Direct          D/-/L/-
     Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                               U-Up/Down Bit Set

[ASG1]display isis 2 route

                         Route information for ISIS(2)
                         -----------------------------

                        ISIS(2) Level-2 Forwarding Table
                        --------------------------------

IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags
-------------------------------------------------------------------------------
172.16.2.20/30       200        NULL    GE0/0/3         172.16.2.18     A/-/-/-
172.16.2.28/30       2000       NULL    GE0/0/1.2       Direct          D/-/L/-
10.0.2.4/32          200        NULL    GE0/0/3         172.16.2.18     A/-/-/-
10.0.2.3/32          100        NULL    GE0/0/3         172.16.2.18     A/-/-/-
172.16.2.16/30       100        NULL    GE0/0/3         Direct          D/-/L/-
172.16.2.24/30       400        NULL    GE0/0/3         172.16.2.18     A/-/-/-
     Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                               U-Up/Down Bit Set

3、配置U2000网管服务器与RSG之间对接,采用VRRP保护方式,将U2000网管路由引入核心汇聚层ISIS中,实现核心汇聚设备的管理。

RSG1:

// 建立VLAN并配置vlan trunk
[RSG1]vlan 100
[RSG1-vlan100]quit
[RSG1]interface GigabitEthernet0/0/3
[RSG1-GigabitEthernet0/0/3]portswitch
[RSG1-GigabitEthernet0/0/3]port link-type trunk
[RSG1-GigabitEthernet0/0/3]port trunk allow-pass vlan 100
[RSG1-GigabitEthernet0/0/3]quit
[RSG1]

// 配置VLANIF上的VRRP
[RSG1]interface Vlanif 100
[RSG1-Vlanif100]ip address 172.17.0.2 24
[RSG1-Vlanif100]vrrp vrid 100 virtual-ip 172.17.0.1
[RSG1-Vlanif100]vrrp vrid 100 priority 120
[RSG1-Vlanif100]vrrp vrid 100 preempt-mode timer delay 180
[RSG1-Vlanif100]isis enable 1000
[RSG1-Vlanif100]isis silent//配置IS-IS接口为被动状态,即抑制该接口接收和发送IS-IS报文,但此接口所在网段的路由可以被发布出去。
[RSG1-Vlanif100]quit

RSG2:

// 建立VLAN并配置vlan trunk
[RSG2]vlan 100
[RSG2-vlan100]quit
[RSG2]interface GigabitEthernet0/0/3
[RSG2-GigabitEthernet0/0/3]portswitch
[RSG2-GigabitEthernet0/0/3]port link-type trunk
[RSG2-GigabitEthernet0/0/3]port trunk allow-pass vlan 100
[RSG2-GigabitEthernet0/0/3]quit
[RSG2]

// 配置VLANIF上的VRRP
[RSG2]interface Vlanif 100
[RSG2-Vlanif100]ip address 172.17.0.3 24
[RSG2-Vlanif100]vrrp vrid 100 virtual-ip 172.17.0.1
[RSG2-Vlanif100]isis enable 1000
[RSG2-Vlanif100]isis silent//配置IS-IS接口为被动状态,即抑制该接口接收和发送IS-IS报文,但此接口所在网段的路由可以被发布出去。
[RSG2-Vlanif100]quit
[RSG2]

SW:

// 配置与RSG互联端口为trunk口,与服务器互联端口为access口,VLAN为100
[Huawei]sys SW
[SW]vlan 100
[SW-vlan100]quit    
[SW]interface GigabitEthernet 0/0/1    
[SW-GigabitEthernet0/0/1]port link-type trunk 
[SW-GigabitEthernet0/0/1]port trunk allow-pass vlan 100
[SW-GigabitEthernet0/0/1]quit    
[SW]interface GigabitEthernet 0/0/2
[SW-GigabitEthernet0/0/2]port link-type trunk
[SW-GigabitEthernet0/0/2]port trunk allow-pass vlan 100
[SW-GigabitEthernet0/0/2]quit    
[SW]interface GigabitEthernet 0/0/3
[SW-GigabitEthernet0/0/3]port link-type access
[SW-GigabitEthernet0/0/3]port default vlan 100
[SW-GigabitEthernet0/0/3]quit
[SW]

U2000 Server(NMS):

完成配置后,服务器可ping通VRRP的虚IP,如上图,同时在RSG2上查询VRRP状态如下:

<RSG2>display vrrp 100
  Vlanif100 | Virtual Router 100
    State : Backup
    Virtual IP : 172.17.0.1
    Master IP : 172.17.0.2
    PriorityRun : 100
    PriorityConfig : 100
    MasterPriority : 120
    Preempt : YES   Delay Time : 0 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE
    Virtual MAC : 0000-5e00-0164
    Check TTL : YES
    Config type : normal-vrrp
    Create time : 2020-03-28 18:45:56 UTC-08:00
    Last change time : 2020-03-28 18:48:43 UTC-08:00

配置完成后验证:在核心汇聚设备上可查看到服务器IP路由172.17.0.0/24,同时ping通服务器地址172.17.0.254

<ASG1>display ip routing-table 172.17.0.0
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Table : Public
Summary Count : 1
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

     172.17.0.0/24  ISIS-L2 15   30          D   172.16.1.1      GigabitEthernet
0/0/0

<ASG1>ping 172.17.0.254
  PING 172.17.0.254: 56  data bytes, press CTRL_C to break
    Reply from 172.17.0.254: bytes=56 Sequence=1 ttl=253 time=70 ms
    Reply from 172.17.0.254: bytes=56 Sequence=2 ttl=253 time=70 ms
    Reply from 172.17.0.254: bytes=56 Sequence=3 ttl=253 time=90 ms
    Reply from 172.17.0.254: bytes=56 Sequence=4 ttl=253 time=80 ms
    Reply from 172.17.0.254: bytes=56 Sequence=5 ttl=253 time=60 ms

  --- 172.17.0.254 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 60/74/90 ms

4、配置ASG的ISIS路由引入。即将ISIS 1000中网管路由引入到ISIS 1和ISIS2,同时将ISIS 1和ISIS2中Loopback0和接口地址路由引入到ISIS 1000,实现接入层设备的管理。

ASG1:

// 配置路由策略,将ASG3 loopback 0发布到接入区域。 
[ASG1]ip ip-prefix LoopBack0 index 10 permit 10.0.1.1 32
[ASG1]route-policy LoopBack0 permit node 10
Info: New Sequence of this List.
[ASG1-route-policy]if-match ip-prefix LoopBack0
[ASG1-route-policy]quit

// 在IGP部分配置的基础上针对DCN要增加如下配置,确保CSG节点有U2000的路由。
[ASG1]ip ip-prefix U2000 index 10 permit 172.17.0.0 24
[ASG1]ip ip-prefix acc index 10 permit 0.0.0.0 0 greater-equal 30 less-equal 32
[ASG1]route-policy U2000 permit node 10
Info: New Sequence of this List.
[ASG1-route-policy]if-match ip-prefix U2000
[ASG1-route-policy]quit
[ASG1]route-policy acc deny node 10
Info: New Sequence of this List.
[ASG1-route-policy]if-match ip-prefix U2000
[ASG1-route-policy]quit
[ASG1]route-policy acc permit node 20
Info: New Sequence of this List.
[ASG1-route-policy]if-match ip-prefix acc
[ASG1-route-policy]quit

// 配置路由引入,主ASG设置引入其他ISIS路由cost值为10000
[ASG1]isis 1
[ASG1-isis-1]import-route direct cost 10000 route-policy LoopBack0
[ASG1-isis-1]import-route isis 1000 cost 10000 route-policy U2000
[ASG1-isis-1]quit
[ASG1]isis 2
[ASG1-isis-2]import-route direct cost 10000 route-policy LoopBack0
[ASG1-isis-2]import-route isis 1000 cost 10000 route-policy U2000
[ASG1-isis-2]quit
[ASG1]isis 1
[ASG1-isis-1]import-route isis 1000 cost 10000 route-policy U2000
[ASG1-isis-1]quit
[ASG1]isis 1000
[ASG1-isis-1000]import-route isis 1 cost 10000 route-policy acc
[ASG1-isis-1000]import-route isis 2 cost 10000 route-policy acc
[ASG1-isis-1000]quit
[ASG1]

ASG2:路由策略与ASG相同,配置过程省略,但配置路由引入时备ASG设置引入其他ISIS路由cost值为20000

// 配置路由引入。
[ASG2]isis 1
[ASG2-isis-1]import-route direct cost 10000 route-policy LoopBack0
[ASG2-isis-1]import-route isis 1000 cost 20000 route-policy U2000
[ASG2-isis-1]quit
[ASG2]isis 2
[ASG2-isis-2]import-route direct cost 10000 route-policy LoopBack0
[ASG2-isis-2]import-route isis 1000 cost 20000 route-policy U2000
[ASG2-isis-2]quit
[ASG2]isis 1000
[ASG2-isis-1000]import-route isis 1 cost 20000 route-policy acc
[ASG2-isis-1000]import-route isis 2 cost 20000 route-policy acc
[ASG2-isis-1000]quit

配置完成后验证:CSG上可查看到本接入环设备及端口路由、2台ASG的Loopback0路由和U2000服务器IP路由172.17.0.0/24,同时ping通服务器地址172.17.0.254和ASG的Loopback0地址。

<CSG1>display ip routing-table 172.17.0.0
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Table : Public
Summary Count : 1
Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

     172.17.0.0/24  ISIS-L2 15   10100       D   172.16.2.1      GigabitEthernet
0/0/0

<CSG1>ping 172.17.0.254
  PING 172.17.0.254: 56  data bytes, press CTRL_C to break
    Reply from 172.17.0.254: bytes=56 Sequence=1 ttl=252 time=60 ms
    Reply from 172.17.0.254: bytes=56 Sequence=2 ttl=252 time=110 ms
    Reply from 172.17.0.254: bytes=56 Sequence=3 ttl=252 time=110 ms
    Reply from 172.17.0.254: bytes=56 Sequence=4 ttl=252 time=100 ms
    Reply from 172.17.0.254: bytes=56 Sequence=5 ttl=252 time=90 ms

  --- 172.17.0.254 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 60/94/110 ms

<CSG1>display ip routing-table 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 13       Routes : 13       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       10.0.1.1/32  ISIS-L2 15   10100       D   172.16.2.1      GigabitEthernet
0/0/0
       10.0.1.2/32  ISIS-L2 15   10200       D   172.16.2.6      GigabitEthernet
0/0/1
       10.0.2.1/32  Direct  0    0           D   127.0.0.1       LoopBack0
       10.0.2.2/32  ISIS-L2 15   100         D   172.16.2.6      GigabitEthernet
0/0/1
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
     172.16.2.0/30  Direct  0    0           D   172.16.2.2      GigabitEthernet
0/0/0
     172.16.2.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/0
     172.16.2.4/30  Direct  0    0           D   172.16.2.5      GigabitEthernet
0/0/1
     172.16.2.5/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/1
     172.16.2.8/30  ISIS-L2 15   200         D   172.16.2.6      GigabitEthernet
0/0/1
    172.16.2.12/30  ISIS-L2 15   2100        D   172.16.2.1      GigabitEthernet
0/0/0
     172.17.0.0/24  ISIS-L2 15   10100       D   172.16.2.1      GigabitEthernet
0/0/0

<CSG1>ping 10.0.1.1
  PING 10.0.1.1: 56  data bytes, press CTRL_C to break
    Reply from 10.0.1.1: bytes=56 Sequence=1 ttl=255 time=40 ms
    Reply from 10.0.1.1: bytes=56 Sequence=2 ttl=255 time=40 ms
    Reply from 10.0.1.1: bytes=56 Sequence=3 ttl=255 time=50 ms
    Reply from 10.0.1.1: bytes=56 Sequence=4 ttl=255 time=40 ms
    Reply from 10.0.1.1: bytes=56 Sequence=5 ttl=255 time=50 ms

  --- 10.0.1.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 40/44/50 ms

5、最后全部配置完成后保存配置,待后续实验使用

<RSG1>save all
The current configuration will be written to the device.
Are you sure to continue?[Y/N]y
Info: Please input the file name ( *.cfg, *.zip ) [vrpcfg.zip]:
Mar 28 2020 19:16:01-08:00 RSG1 %%01CFM/4/SAVE(l)[0]:The user chose Y when decid
ing whether to save the configuration to the device.
flash:/vrpcfg.zip exists, overwrite?[Y/N]:y
Now saving the current configuration to the slot 17.
Mar 28 2020 19:16:04-08:00 RSG1 %%01CFM/4/OVERWRITE_FILE(l)[1]:When deciding whe
ther to overwrite the configuration file vrpcfg.zip, the user chose Y.
Save the configuration successfully.
<RSG1>

附件:ensp拓扑组网

设备配置


转载请注明来源,欢迎对文章中的引用来源进行考证,欢迎指出任何有错误或不够清晰的表达。可以在下面评论区评论,也可以邮件至 xumeng32@126.com

文章标题:IPRAN中的IS-IS应用ensp模拟实验

文章字数:4.7k

本文作者:F_numen

发布时间:2020-03-28, 15:06:25

最后更新:2020-03-28, 21:44:10

原始链接:https://netheroone.cn/archives/10a3834e.html

版权声明: "署名-非商用-相同方式共享 4.0" 转载请保留原文链接及作者。

目录
/*baidu统计*/